Personal tools
User menu

Fixing legacy BlueBerry bundles

From mitk.org

Jump to: navigation, search

Legacy BlueBerry bundles can still be used in the new CTK-based BlueBerry system. However, in some cases, source code compatibility could not be maintained. Please check the list below if you need to make changes to your bundle in order to compile and run it under the new system.

  • Your bundle contributes a view to the BlueBerry workbench.
    If that is the case, you might have to fix a multiple QObject inheritance problem. The class berry::WorkbenchPart now inherits from QObject, hence any derived class must not inherit from QObject again. Just remove the inheritance from your view class (and leave the Q_OBJECT macro).
  • This page was last modified on 19 November 2014, at 14:54.
  • This page has been accessed 5,419 times.