Naming Conventions

From mitk.org
Revision as of 16:14, 9 June 2016 by JasminMetzger (talk | contribs) (Add link to style guide in the nigthly documentation)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

This page is about naming conventions of application and module source directories and build artifacts. For more naming conventions and MITK style guide, please have a look here.


Situation until 2013.12

Until MITK 2013.12 there was no official naming scheme, resulting in a mix of different styles.


Source tree

<syntaxhighlight lang="cpp"> Applications/

 CoreApp
 mitkWorkbench

Modules/

 CameraCalibration
 MitkAlgorithmsExt
 Qmitk
 QmitkExt
 QmlMitk

</syntaxhighlight>


Build artifacts

Current build artifacts in MITK-build/bin:

<syntaxhighlight lang="cpp"> ImageExtractionTestDriver MitkTestDriver mitkCameraCalibrationTestDriver

mitkWorkbench CoreApp mitkIGTTutorialStep1 Step1

libConnectomics.so libMitkAlgorithmsExt.so libmitkCameraCalibration.so libQmitk.so libQmlMitk.so ... </syntaxhighlight>


Change proposal

  1. No "mitk" string in source tree directories. There is no need to state that a module or appication belongs to "mitk", since it is already contained in the MITK source tree.
  2. All build artifacts and module names are prefixed with "Mitk" (the prefix will be configurable for external projects). Module names are visible from external projects and should carry a prefix identifying the project where the module is hosted. The same is true for build artifact names like shared library names.
  3. Qt dependent module directories and module names are prefixed with "Qt" or "Qml" (some modules will need to be renamed). They will then also additionally get the "Mitk" prefix.


New source tree layout

<syntaxhighlight lang="cpp"> Applications/

 CoreApp
 Workbench  ← previously "mitkWorkbench"

Modules/

 CameraCalibration
 AlgorithmsExt      ← previously "MitkAlgorithmsExt"
 QtWidgets          ← previously "Qmitk"
 QtWidgetsExt       ← previously "QmitkExt"
 QmlWidgets         ← previously "QmlMitk"

</syntaxhighlight>


New build artifact naming

New build artifacts in MITK-build/bin:

<syntaxhighlight lang="cpp"> MitkImageExtractionTestDriver ← previously "ImageExtractionTestDriver" MitkTestDriver MitkCameraCalibrationTestDriver ← previously "mitkCameraCalibrationTestDriver"

MitkWorkbench ← previously "mitkWorkbench" MitkCoreApp ← previously "CoreApp" MitkIGTTutorialStep1 ← previously "mitkIGTTutorialStep1" MitkStep1 ← previously "Step1"

libMitkConnectomics.so ← previously "libConnectomics.so" libMitkAlgorithmsExt.so libMitkCameraCalibration.so ← previously "libmitkCameraCalibration.so" libMitkQtWidgets.so ← previously "libQmitk.so" libMitkQmlWidgets.so ← previously "libQmlMitk.so" </syntaxhighlight>